FI Beetle - German Plenum/TB,EDIS,MS1,K24 Turbo

Step by step

Re: FI Beetle - German Plenum/TB,EDIS,MS1,K24 Turbo

Postby Vee Dub Nut » Sat Feb 20, 2010 10:22 pm

Yes sir.. already using them on my fuel lines.
Random avatar
Vee Dub Nut
 
Posts: 31
Joined: Thu Dec 10, 2009 7:55 am
Location: San Antonio, TX

Re: FI Beetle - German Plenum/TB,EDIS,MS1,K24 Turbo

Postby vdubjim » Sun Feb 21, 2010 9:49 am

when i first saw them i couldnt believe it. they rock!
User avatar
vdubjim
Site Admin
 
Posts: 204
Joined: Sat Dec 05, 2009 10:28 am
Location: Oklahoma

Re: FI Beetle - German Plenum/TB,EDIS,MS1,K24 Turbo

Postby Vee Dub Nut » Mon Mar 01, 2010 10:08 pm

My first impressions... MAN I LOVE THE SOUND OF THAT TURBO. There is just something about the sound of it spooling up as your pulling away from a stop. Makes me smile every time :mrgreen:

So I'm still VERY rough on tuning. I spent a lot of time over the weekend sorting out other small problems that didn't leave me as much time to tune as I wanted to. My plan was to start it up on Saturday, set the idle up, then start tuning the VE table. What actually happened was that I spent half the day chasing my tail trying to start the engine trying to figure out if I was having starter problems or ignition problems. In the end, it turned out it was both. Once I finally gave in a went to the autoparts store to pick up a new starter, then I was actually able to crank the engine over enough to figure out that my timing was out of phase. Turns out I just had my EDIS A and B coil triggers reversed. Oh and by the way, this is another plug for Mario. He told me to call him if I was having any trouble when I was working on it, and we talked two or three times throughout the day. It sure was great to have someone to bounce ideas off of. Excellent service!!!!

After I got it started it ran smooth as can be. I let it warm up and did a little tuning on the idle VE values to get a good MAP. During this time I noticed a few small oil leaks from my new full flow lines, and that my silicon hoses on my intake runners would halfway collapse under vacuum. So at the close of Saturday I spent my time fixing the few leaks and slipping in some 1.5" OD stainless tubing into my silicon runners to keep them from collapsing.

Sunday started with a little bit of struggling. I was having trouble starting it again and couldn't figure out how it ran so great the day before, but I couldn't get it running worth a crap then. Turns out during my maintenance the night before, I switched a couple of plug wires around. Oops :oops: Once that was fixed it fired right up. After that I spent some time driving around doing data logs but by the end of the day I didn't like where it was headed, so I back tracked a little bit after changing some of my settings in Megatune. This was mostly my fault. I goofed on my AFR target table. I'm primairly using data logs and megalog VE analyzer for tuning right now. If I don't get the results I'm looking for, I'll do more by hand.

Anyway.. here is proof that it runs. Keep in mind this is with very little tuning, and my accel enrichments are completely off (yes I figured out I don't have to turn of my accel enrichments for megalog viewer, it has that nice fancy filter that will over look them).

Removed the video.. see the more current one with a good tune in posts below.
Last edited by Vee Dub Nut on Tue Mar 02, 2010 7:06 pm, edited 1 time in total.
Random avatar
Vee Dub Nut
 
Posts: 31
Joined: Thu Dec 10, 2009 7:55 am
Location: San Antonio, TX

Re: FI Beetle - German Plenum/TB,EDIS,MS1,K24 Turbo

Postby Vee Dub Nut » Mon Mar 01, 2010 10:09 pm

Oh.. also so far I have not noticed ANY drain back issues with my set-up. Here is a picture:

Image
Random avatar
Vee Dub Nut
 
Posts: 31
Joined: Thu Dec 10, 2009 7:55 am
Location: San Antonio, TX

Re: FI Beetle - German Plenum/TB,EDIS,MS1,K24 Turbo

Postby vdubjim » Mon Mar 01, 2010 11:31 pm

cool vid!
Nice to see it running!!
User avatar
vdubjim
Site Admin
 
Posts: 204
Joined: Sat Dec 05, 2009 10:28 am
Location: Oklahoma

Re: FI Beetle - German Plenum/TB,EDIS,MS1,K24 Turbo

Postby Vee Dub Nut » Tue Mar 02, 2010 8:14 am

Thanks... I was glad to finally see it running again too. :D
Random avatar
Vee Dub Nut
 
Posts: 31
Joined: Thu Dec 10, 2009 7:55 am
Location: San Antonio, TX

Re: FI Beetle - German Plenum/TB,EDIS,MS1,K24 Turbo

Postby vdubjim » Tue Mar 02, 2010 8:48 am

makes me want to turbo mine :)

now i just gotta get this manifold fabrication figured out :evil:

once you get your tuning straight, upload the map to help others out here :idea:
User avatar
vdubjim
Site Admin
 
Posts: 204
Joined: Sat Dec 05, 2009 10:28 am
Location: Oklahoma

Re: FI Beetle - German Plenum/TB,EDIS,MS1,K24 Turbo

Postby Vee Dub Nut » Tue Mar 02, 2010 9:04 pm

A much better video I made today

http://www.youtube.com/watch?v=mWPmNeomoV4

I'll try and get a driving one this weekend. :D
Random avatar
Vee Dub Nut
 
Posts: 31
Joined: Thu Dec 10, 2009 7:55 am
Location: San Antonio, TX

Re: FI Beetle - German Plenum/TB,EDIS,MS1,K24 Turbo

Postby Vee Dub Nut » Tue Mar 02, 2010 9:15 pm

So I made a new VE map from my datalog that I took yesterday with my corrected AFR target table, and the car works MUCH better. I also advanced my timing some up on boost as I took it very conservative in the beginning, and the results are great! I'm maxing out at 5lbs of boost right now, and my peak duty cycle on the injectors was 86%. So I think I'm just about at the limit. Since I'm still running a cast crank anyways, I wont be turning the wastegate in any more until I can build up my engine. I don't want to take any unnecessary chances and gamble breaking my crank and ruining the rest of my engine.

The only thing I noticed that I needed to work on is my accel enrichment's. I could feel them kicking in and out when accelerating, and you can see them clear as day in the data logs.

Here is my current spark map:

Image

Enjoy!
Random avatar
Vee Dub Nut
 
Posts: 31
Joined: Thu Dec 10, 2009 7:55 am
Location: San Antonio, TX

Re: FI Beetle - German Plenum/TB,EDIS,MS1,K24 Turbo

Postby vdubjim » Sat Nov 05, 2011 11:17 am

any updates?
User avatar
vdubjim
Site Admin
 
Posts: 204
Joined: Sat Dec 05, 2009 10:28 am
Location: Oklahoma

Previous

Return to Complete Installs

cron
Hosted by Freeforum.ca, get your free forum now! TOS | Support Forums | Report a violation
buying traffic website
MultiForums powered by echoPHP phpBB MultiForums